Knowledge - Details


Fix a hotel's captive portal using a non-SSL website (httpforever.com)
Date Added: 1/24/2024

PROBLEM:
You've connected to a hotel's Wi-Fi, but you cannot access any websites or internet services.  Maybe it worked earlier, but stopped working recently.

CAUSE:
Hotels and other public Wi-Fi hotspots like to use captive portals that hijack your internet connection to force you to visit their special sign-in page, where you typically enter a password or room number, and then must agree to their hotspot's terms and conditions.  These captive portals cannot redirect secure connections (websites that use SSL/TLS/https), so your internet just stays broken.

SOLUTION:
1) Connect to their Wi-Fi
2) In your web browser, go to http://httpforever.com (or any website that doesn't use https, which is rare nowadays)
3) It should redirect you to the hotel's captive portal authentication page.  Follow the hotel's instructions on that page to unlock your internet.
4) Now, your internet should work normally from that device until the hotel expires your authentication, and you must do this all over again.
5) If the above doesn't work, it may help to disconnect from their Wi-Fi and reconnect to it.
6) If that doesn't work, call the hotel lobby to ask for their help.

Last, consider a complaint to the hotel that their captive portal is unintuitive, inconvenient, and insecure.
* It broke your internet without telling you what the problem was, so you had to waste time searching for a solution.
* It could disconnect your internet without warning while you are in the middle of an important meeting until you renew the captive portal process again.
* It works by hijacking your internet connection and redirecting your traffic from your intended website to a different server, which is bad for your security.



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Disclaimer: Everything on this website is written for my own use. I disclaim any guarantees that the procedures and advice listed here are accurate, safe, or beneficial for anyone else. If you attempt to follow any procedures or advice shared here, you do it at your own risk. Part of IT work is knowing how to recover from problems.